⚡当前语言可能更新不及时,最新信息请以英文文档为准。如果翻译有问题,请告诉我们

# 多语言支持

为您的 Flarum 添加新的界面语言很简单。按照下面的说明,下载并安装语言包即可。

在您安装并启用一个语言包后,您可以将其 设置为您论坛的默认语言。当您可以 随时禁用 用不到的语言。如果您有使用任何第三方扩展,请务必在开始前 阅读社区扩展说明

# 安装语言包

欲开始,请访问 Flarum 社区上的 Extensions > Languages (opens new window) 标签,并找到您想要安装的语言包。

语言包的安装方式与 扩展 相同。语言包安装成功后会出现在后台管理界面的 Extensions(插件) 页面中,您可以在该页面启用语言包。

完成!您现在应该可以点击论坛顶部导航栏的语言选择器,将界面切换到新语言。

# 设置默认语言

如果安装的语言包能正常工作,您可能会想要将该语言设置为新用户和访客的默认语言。您可以在后台管理面板的 Basics(常规) 页面中进行设置。

# 禁用语言包

当您不需要某种语言时,您可以选择关闭该语言。只需在后台管理面板的 Extensions(插件) 页面中找到该语言包,然后将其关闭该语言包。

如果您的网站是单语网站,并且不希望语言选择器出现在论坛顶部的导航栏中,您可以禁用其他语言包。当只有一种语言包处于启用状态时,语言选择器会自动隐藏。

# 社区扩展

虽然从 Flarum 社区中下载的语言包通常是包含所有 Flarum 原生捆绑扩展的翻译的,但是 并没有规定说 语言包必须翻译了所有您安装的社区扩展。是否提供、更新维护这些扩展的翻译取决于开发者的个人意愿。

因此,在您安装一个社区扩展前,请检查您使用的语言包是否包含了该扩展的翻译,如果您发现语言包没有翻译该扩展,请直接联系语言包的开发者,让他/她添加翻译。