# Diller

Temel Flarum kurulumunuza yeni bir dil eklemek kolaydır. Seçtiğiniz dil paketini indirmek ve kurmak için aşağıdaki talimatları uygulamanız yeterlidir.

Bir dil paketi ekledikten sonra, forumunuz için varsayılan dil olarak ayarlayabilirsiniz. Ve yüklü dil paketlerinizden birine ihtiyacınız olmadığını anlarsanız, her zaman [devre dışı bırakabilirsiniz] (#dil-paketini-devre-dışı-bırakma). Herhangi bir üçüncü taraf uzantısı kullanıyorsanız, başlamadan önce bunu okuduğunuzdan emin olun.

# Dil Paketi Kurulumu

Başlamak için, Flarum Community sitesinde Extensions > Languages (opens new window) etiketini ziyaret edin ve yüklemek istediğiniz bir dil paketi bulun.

Dil paketleri, uzantılar ile aynı şekilde yüklenir. Dil, yönetici arayüzünün Uzantılar sayfasında görünecektir ve orada etkinleştirebilirsiniz.

Hepsi bu kadar! Artık forumunuzun görünümünü yeni dile geçirmek için sitenizin başlığındaki dil seçiciyi kullanabilmeniz gerekir.

# Varsayılan Dili Ayarlama

Bir dil paketi yükledikten ve çalıştığından emin olduktan sonra, onu yeni kullanıcılar ve misafirler için varsayılan dil olarak ayarlamak isteyebilirsiniz. Bunu yönetici arayüzünün Temel Bilgiler sayfasında yapabilirsiniz.

# Dil Paketini Devre Dışı Bırakma

Belirli bir dili desteklemenize gerek olmadığına karar verirseniz, sonuçta onu kapatabilirsiniz. Yönetici arayüzünün Uzantılar sayfasında dil paketini bulun ve devre dışı bırakın.

Tek dilli bir site çalıştırıyorsanız ve dil seçicinin site başlığında görünmesini istemiyorsanız, bir dili devre dışı bırakmak yararlı olabilir. Dil seçici, yalnızca bir dil etkinleştirildiğinde gizlenir.

# Topluluk Uzantıları

Flarum Topluluğu sitesinden indirilen dil paketleri genellikle Flarum ile birlikte gelen tüm uzantıların çevirilerini içerecek olsa da, kural olarak yüklemiş olabileceğiniz tüm topluluk uzantılarını kapsamazlar. Uzantılarının çevirilerini sağlamak ve sürdürmek geliştiricilere bağlıdır.

Bu nedenle, bir topluluk uzantısı yüklemeden önce, yüklediğiniz her dil paketi için çeviriler içerdiğinden emin olmalısınız. Bir uzantının ihtiyacınız olan bir dili desteklemediğini fark ederseniz, lütfen doğrudan geliştiriciyle iletişime geçin ve gerekli çevirilerin eklenmesini sağlayın.